origin storage is down
Incident Report for CacheFly
Resolved
Origin service are back online
Posted about 1 month ago. May 17, 2019 - 00:38 CDT
Investigating
We are currently investigating.
Posted about 1 month ago. May 17, 2019 - 00:08 CDT
This incident affected: Origin - FTP and Origin - SSH.